[cctbxbb] bootstrap.py build on Ubuntu

Nicholas Sauter nksauter at lbl.gov
Thu Jan 7 09:30:14 PST 2016


I notice that the Pango version, 1.16.1, was released in 2007, so perhaps
it is no surprise that the latest Ubuntu does not support it.  Maybe this
calls for stepping forward the Pango version until you find one that works.
I see that the latest stable release is 1.39.

This would be valuable information for us..Billy Poon in the Phenix group
is supporting the Phenix GUI, so it might be advisable for him to update
the Pango version in the base installer.


Nicholas K. Sauter, Ph. D.
Computer Staff Scientist, Molecular Biophysics and Integrated Bioimaging
Lawrence Berkeley National Laboratory
1 Cyclotron Rd., Bldg. 33R0345
Berkeley, CA 94720
(510) 486-5713

On Thu, Jan 7, 2016 at 8:54 AM, David Waterman <dgwaterman at gmail.com> wrote:

> Hi again
> Another data point: I just tried this on a different Ubuntu machine, this
> time running 14.04. In this case pango installed just fine. In fact all
> other packages installed too and the machine is now compiling cctbx.
> I might have enough for comparison between the potentially working 14.04
> and failed 15.04 builds to figure out what is wrong in the second case.
> Cheers
> -- David
> On 7 January 2016 at 09:56, David Waterman <dgwaterman at gmail.com> wrote:
>> Hi folks
>> I recently tried building cctbx+dials on Ubuntu 15.04 following the
>> instructions here:
>> http://dials.github.io/documentation/installation_developer.html
>> This failed during installation of pango-1.16.1. Looking
>> at pango_install_log, I see the command that failed was as follows:
>> gcc -DHAVE_CONFIG_H -I. -I. -I../..
>> -DSYSCONFDIR=\"/home/fcx32934/sw/dials_bootstrap_test/base/etc\"
>> -DLIBDIR=\"/home/fcx32934/sw/dials_bootstrap_test/base/lib\"
>> -I/home/fcx32934/sw/dials_bootstrap_test/base/include
>> -I/home/fcx32934/sw/dials_bootstrap_test/base/include/freetype2 -g -O2
>> -Wall -MT fribidi.lo -MD -MP -MF .deps/fribidi.Tpo -c fribidi.c  -fPIC
>> -DPIC -o .libs/fribidi.o
>> In file included from fribidi.h:31:0,
>>                  from fribidi.c:28:
>> fribidi_config.h:1:18: fatal error: glib.h: No such file or directory
>> The file glib.h appears to be in base/include/glib-2.0/, however this
>> directory was not explicitly included in the command above, only its
>> parent. This suggests a configuration failure in pango to me. Taking a look
>> at base_tmp/pango-1.16.1/config.log, I see what look like the relevant
>> lines:
>> configure:22227: checking for GLIB
>> configure:22235: $PKG_CONFIG --exists --print-errors "$GLIB_MODULES"
>> configure:22238: $? = 0
>> configure:22253: $PKG_CONFIG --exists --print-errors "$GLIB_MODULES"
>> configure:22256: $? = 0
>> configure:22304: result: yes
>> but this doesn't tell me very much. Does anyone have any suggestions as
>> to how I might proceed?
>> Many thanks
>> -- David
> _______________________________________________
> cctbxbb mailing list
> cctbxbb at phenix-online.org
> http://phenix-online.org/mailman/listinfo/cctbxbb
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://phenix-online.org/pipermail/cctbxbb/attachments/20160107/0d33e8b5/attachment.htm>

More information about the cctbxbb mailing list