[phenixbb] Problem in Autosol

Eric Tee ericteework at googlemail.com
Sun Sep 16 11:05:02 PDT 2007

Hi Tom,
Many thanks for your reply. I was running phenix in my d_drive (a vfat
partition) and got the error message. However, when I moved the mtz file to
a directory under home directory (home/user/phenix-local), The program work
without any problem. Let me explain how this work:

I'm running phenix on fedora7 (a dual boot machine with Windows). I
installed phenix under home/user/program/phenix (not /usr/local). I have a
vfat partition (as d_drive) where I keep all my data and basically process
everything there. I got the error message if I run phenix in the vfat
partition but the program can be run successfully under the home directory

Following is what I got if I run phenix in the vfat partition (d_drive):
WORKDIR: /mnt/d_drive/ccp4_data/SAD/phenix-localmachine
Checking for KnownWizards:  ['AutoSol', 'AutoBuild', 'ImportRawData']
application method:  Null
Getting inputs on first pass...
SETTING UP INPUTS AutoSol Wizard                Screen 1 of 4

               AutoSol: Choose data files for dataset #1

               A "dataset" is a group of data with a single set of
heavy-atom sites

               You will be able to combine the results of all  datasets

               Note: Data files can be any format. If they are not all
Scalepack premerged or all
               Scalepack unmerged then all will be converted to Scalepack

SUMMARY Input files dataset #1

Creating new Data Storage
sh: TEMP0/temporary.com: Permission denied

Could be something related to permission problem but I have set permission
to read/write/execute in vfat partition by adding the following line to
/dev/sda6    /mnt/d_drive    vfat
users,uid=eric,gid=users,umask=0002,utf8=true    0 0

Any suggestion to enable running phenix in the vfat partition?


On 9/16/07, Tom Terwilliger <terwilliger at lanl.gov> wrote:
> Hi Eric,
> Can you possibly check to see that you have a recent version of phenix:
> phenix.version will do this.
> Then if that is ok, I'm not sure what is causing the problem. This
> message means that solve could not run with the data it got, but
> usually an error message should come up earlier if there is a
> problem.  Have a look at LAST.LOG in your AutoSol directory and see
> if it has any hints. Also look at AutoSol_run_1_.output and see the
> end of this log file.
> If none of those work, if you can send me your input data file I can
> see if there is a problem with it (all I would need is the first 100
> lines or so).
> -Tom T
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://phenix-online.org/pipermail/phenixbb/attachments/20070916/bcd268dc/attachment-0003.htm>

More information about the phenixbb mailing list